구매안내 온라인 문의

Apache Struts 2 원격 코드 실행 취약점 주의 권고

2018-11-08 NEW

▷ 개요

l   Apple社는 Apache Struts2에서 낮은 버전의 라이브러리를 사용하여 원격 코드 실행이 가능한 취약점 존재 [1]

l   공격자는 해당 취약점을 악용하여 악성코드 감염 등의 피해를 발생시킬 수 있으므로, 영향 받는 버전을 사용하는 이용자들은 아래 해결방안에 따라 조치 권고

(※ 과거에 발견된 취약점이지만 미 조치된 시스템을 대상으로 해당 취약점을 악용한 공격이 우려되어 이용자 주의 재차 권고)

 

▷ 내용

l   commons-fileupload 라이브러리에서 발생하는 원격 코드 실행 취약점(CVE-2016-1000016) [2]

 

▷ 영향을 받는 시스템

l   Safaricommons-fileupload 1.3.3 이전 버전을 사용하는 경우

- Apache Struts 2.3.36 및 이전 버전 (Apache Struts 2.5.12 및 이후 버전은 해당 없음)

 

▷ 해결 방안

l   WEB-INF/lib 경로의 commons-fileupload 라이브러리를 최신 버전(1.3.3)으로 교체 [3]

 

▷ 참고 사이트

- [1] http://mail-archives.us.apache.org/mod_mbox/www-announce/201811.mbox/%3CCAMopvk

Mo8WiP%3DfqVQuZ1Fyx%3D6CGz0Epzfe0gG5XAqP1wdJCoBQ%40mail.gmail.com%3E

- [2] https://nvd.nist.gov/vuln/detail/CVE-2016-1000031

- [3] https://issues.apache.org/jira/browse/WW-4812

 

  • 목록