보안공지

구매안내 온라인 문의

BIND DNS 신규 취약점 보안 업데이트 권고

2017-06-17

▷ 개요

l   ISC BIND DNS에서 발생하는 원격 서비스 거부(Denial of Service) 취약점을 해결한 보안 업데이트를 발표 

  

▷ 내용

l   RPZ기능이 사용된 BIND 네임서버에 특정한 형태의 질의가 들어올 경우 질의응답 처리가 완료되지 않고 무한 루프에 빠지는취약점(CVE-2017-3140) [1]

   영향 받는 제품 및 버전

    BIND 9.9.10, 9.10.5, 9.11.0 ~ 9.11.1, 9.9.10-S1, 9.10.5-S1  

l   Windows 시스템에서 사용되는 BIND 설치 프로그램이 서비스 및 삭제 경로를 제대로 처리하지 않아, 이를 이용해 로컬 사용자가 높은 권한을 획득 가능한 취약점(CVE-2017-3141) [2]   

     Windows BIND 설치 프로그램의 취약점으로, OS BIND는 영향 받지 않음 

    - 영향 받는 소프트웨어 

     BIND 9.2.6-P2 ~ 9.2.9, 9.3.2-P1 ~ 9.3.6, 9.4.0 ~ 9.8.8, 9.9.0 ~ 9.9.10, 9.10.0 ~ 9.10.5, 9.11.0 ~ 9.11.1, 9.9.3-S1~9.9.10-S1, 9.10.5-S1 

 

▷ 해결 방안

l   BIND 버전 업그레이드를 통한 조치

   - BIND 9.9.10-P1, 9.10.5-P1, 9.11.1-P1, 9.9.10-S2, 9.10.5-S2로 업그레이드

 

l   설정에 의한 조치  

   - CVE-2017-3140 : RPZ 설정 시 NSDNAME 또는 NSIP를 사용하지 않도록 조치 

   - CVE-2017-3141 : 설정에 의한 조치방법 없음

 


▷ 참고 자료

- [1] https://kb.isc.org/article/AA-01495/  

- [2] https://kb.isc.org/article/AA-01496  


 

  • 목록