보안공지

구매안내 온라인 문의

Apache Log4j 역직렬화 취약점 업데이트 권고

2017-04-20

 

▷ 개요

l   Apache Log4j에서 임의 코드 실행이 가능한 취약점을 해결한 보안 업데이트 발표

l   취약한 버전을 사용 중인 서버의 담당자는 해결방안에 따라 최신 버전으로 업데이트 권고

 

▷ 내용

l   Log4j모듈이 로그 이벤트를 역직렬화 하는 과정에서 임의 코드 실행이 가능한 취약점(CVE-2017-5645)

 

▷ 영향 받는 제품

l   영향 받는 제품 및 버전

- Apache Log4j 2.0-alpha1 ~ 2.8.1

 

▷ 해결방안

l   Apache Log4j 2.8.2 버전으로 업데이트 수행

l   socket server class 사용 금지

l   AbstractSocketServer에 클래스 필터링 추가

 

▷ 권고 사항

l   해당 취약점은 영향력 확인 및 보안 업데이트를 권고 드립니다.


▷ 참고 자료

- https://issues.apache.org/jira/browse/LOG4J2-1863
- https://git-wip-us.apache.org/repos/asf?p=logging-log4j2.git;h=5dcc192

 

  • 목록